Symptom
- A discrepancy is observed when searching for tickets using the ticket content in different work centers.
- In the Customer > Tickets > Advanced search, when the ticket content is entered in the Description field, no results are returned.
- However, when the same content is entered in the Ticket content field of Service > Tickets > Advanced search, the results are displayed as expected.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Customer > Individual Customer > Tickets > Advanced Search
- Enter Description = ABC, hit Go (ABC represents a description content of the ticket)
- Observe that no results are returned, even though tickets with this text "ABC" in the description exist
- Now navigate to Service > Tickets > Advanced Search
- Enter Ticket Content = ABC, hit Go
- Observe that the relevant ticket(s) is returned in the search results
Cause
Description field is bound with value in /Root/SearchParams_Tickets/Name, which should be the ticket subject.
It's showing the ticket subject, not description content.
Resolution
This is the standard behavior of the system.
Keywords
Ticket Search, Discrepancy, Customer Work Center, Service Work Center, Advanced Search, Ticket Content, Description, Subject, C4C , KBA , LOD-CRM-SRP , Service Request Processing , Problem
Product
SAP Cloud for Customer core applications all versions