Symptom
The CDS view I_KR_EDCIncgTaxAuthDocument which is marked as 'Released', cannot be found or accessed in the Customer Data Browser application.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Open the Customer Data Browser application.
- Attempt to search for the CDS View I_KR_EDCIncgTaxAuthDocument.
- No result will show for the CDS View.
Cause
- The CDS View is being blocked by Access Control.
- Despite the standard CDS View I_KR_EDCIncgTaxAuthDocument being released, it has the annotation @AccessControl.authorizationCheck: #PRIVILEGED_ONLY therefore it cannot be accessed directly through the application 'Customer Data Browser'.
- This status can be verified within the 'View Browser' application under the tab 'Annotation'.
Resolution
As a workaround, you can perform the following steps:
- Open the application 'Custom CDS Views' and create a new Custom CDS View.
- Select I_KR_EDCIncgTaxAuthDocument as its primary data source.
- Open the Customer Data Browser and search for the newly created Custom CDS View.
Keywords
Standard, CDS View, I_KR_EDCIncgTaxAuthDocument, Released, Inaccessible, Customer Data Browser, #PRIVILEGE_ONLY, Authorization Check, Custom CDS View, Primary Data Source, Access Control, Annotation, View Browser , KBA , BC-SRV-APS-CDB , Customer Data Browser , How To
Product
SAP S/4HANA Cloud Public Edition all versions