Symptom
You noticed that when selecting Account within Target Group and filtering by "Main Contact", it doesn't return only the main Contacts, but all the Contacts in the system.
Environment
- SAP Sales Cloud Version 2
- SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to Target Groups.
- Select a Target Group.
- Click the "Add Accounts" button.
- You will see the filter "Main Contact".
- If you click it, all the Contacts are appearing, not only the Main (Primary) Contacts.
Cause
The label 'Main Contact' indicates that the filter is applied based on the primary contacts of the Accounts. However, it does not mean that the value help only returns contacts marked specifically as 'Main Contacts'.
Also, in other value helps, we don’t restrict the options based on what is currently maintained in the Account OWL. For example, when selecting an ABC Classification, you can choose any value—even if that value hasn’t been used or maintained in the data yet.
Resolution
This is the expected behavior of the system.
Keywords
Filter , Main Contact , Primary , Target Group , Account , Value , Return , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , Problem