Symptom
Visit can be closed although the mandatory survey is not completed
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to Visits work center
- Open any In-Process Visit
- Go to the Survey Tab
- Observe: The Survey is still opened although the scoping question is enable
Cause
The Complete Mandatory Items Before Closing Visits business option allows you to enforce the mandatory setting for tasks and surveys. If your sales or service representatives have not completed all the mandatory items within a visit, they cannot close the visit.
Resolution
'Mandatory Items' = Your Survey should be mandatory we have to enable the mandatory column in adaptation in the Visit/Survey Tab and set the mandatory flag in your activity plan accordingly.
Keywords
Mandatory Items, Survey, mandatory column, Activity plan , KBA , LOD-CRM-ACT-VST , Visit Planning , Problem