SAP Knowledge Base Article - Public

3596421 - For some users email address is not getting saved in lower case in SAP Analytics Cloud (SAC).

Symptom

For some user, the email id is not getting saved in lowercase in SAC.

Environment

SAP ANALYTICS CLOUD Version 2024.21.11 

Reproducing the Issue

  1. Login to SAC having setup with custom IdP.
  2. In Security --> Users change email address from uppercase to lowercase.
  3. Save the changes.

Notice that the email id is still in uppercase.

Cause

While switching to custom IdP email is selected instead of "Custom SAML mapping" in the user attribute.
The user email in SAC is reflected as it is in the IdP Side.

Resolution

The user email in SAC is reflected as it is in the IdP Side. If we change it to lowercase, it will lock out the users from the tenant due to case sensitivity.

If displaying the email in lowercase is necessary, then would have to do the following:

1. Revert back to the default IdP.
Disable SAML SSO

2. Perform the changes in the IdP to convert into lowercase.

3. Then change back to the custom IdP
Enable a Custom SAML Identity Provider

See Also

Keywords

SAC, SAP Analytics Cloud, idp, custom, switch, user, attribute, lowercase, uppercase , KBA , LOD-ANA-ADM , SAC Administration , Problem

Product

SAP Analytics Cloud 1.0