SAP Knowledge Base Article - Public

3596435 - Generate Summary function in Ticket not working

Symptom

Error during Document cannot be generated; ADS server returned an SOAP error'.

 

Environment

SAP Cloud for Customer core applications 

Reproducing the Issue

1. Go to Service Work Center.
2. Open Tickets Work Center View.
3. Open Ticket 123(where 123 is the ID of the Ticket).
4. Click on Actions and select Generate Summary option.
5. In the pop-up, select a form template and click on Generate.

Notice that the screen loads for sometime and error occurs as- 'Document cannot be generated; ADS server returned an SOAP error'.

 

Cause

This error message means that the document XML which the Ticket application generates for the output is too large and the ADS server is unable to process it. This can happen, for example, when there are too many Interactions with multiple Inline images in it.

Resolution

In order to resolve the issue, follow the below steps:

  1. Go to Administrator Work Center.
  2. Navigate to Service and Social Work Center View.
  3. Open Ticket Configuration.
  4. In Output Management section, enable the 'Disable Interactions' option and disable the 'Enable Inline Images' option.

This will ensure that Interactions and Inline images are not included in the generated Ticket summary.

Keywords

ADS, SOAP Error, Ticket, Summary, Preview, Document, Form Template. , KBA , LOD-CRM-SRP , Service Request Processing , Problem

Product

SAP Cloud for Customer core applications all versions