SAP Knowledge Base Article - Public

3596472 - Troubleshooting Time Alerts in SAP SuccessFactors Employee Central

Symptom

  • In SAP SuccessFactors Employee Central, issues are encountered while trying to resolve time alerts in the time management workbench.
  • The category of all time alerts is "Recalculate Absences".
  • Upon clicking "Recalculate Absences" under actions, a recalculation process seems to start and finish, but it does not resolve any of the displayed time alerts.
  • An error message is displayed stating "The employee time of user [UserID] cannot be updated because of an error in another record."

Environment

  • Employee Central Time Off
  • Recalculation

Reproducing the Issue

  1. Go to admin alerts
  2. Select Admin Alert Type 'Recalculate Absences'
  3. Click on the record of PersonID [UserId] (This will redirect to time management workbench)
  4. On the time alert tab, click "Recalculate Absences"
  5. Refresh the page after the background process has finished
  6. None of the Listed errors is resolved.

Cause

The issue arises due to an error in another record which was not initially identified.

Resolution

1. The first step is to identify the true record causing the error. You may notice some records displaying the message "The employee time of user [UserID] cannot be updated because of an error in another record." These are generic messages and can be ignored.

2. The actual issue will have a more meaningful message, such as "Your requested time off must include at least one workday. Please change the dates you've entered accordingly." Please read this message carefully and check the record to verify it.

3. Once you've identified the issue, the next step is to take appropriate action to fix it. In this case, it appears the absence was created for a non-working day, or there was temporary time information that changed this date from working to non-working, or the holiday calendar was updated.

4. After correcting the issue, please run the recalculation again.

You may also noticed an error message stating "The absences of user [UserID] are not processed automatically anymore because they were unsuccessfully recalculated 3 times." This indicates that there's an underlying issue that needs to be addressed. Once the primary issue is resolved, the recalculation error should also be corrected.

Here's what you need to do:

1. Identify and resolve the issue described in the alert.
2. Run the recalculation again.

Keywords

SAP SuccessFactors, Employee Central, time alerts, Recalculate Absences, error in another record, time management workbench, admin alerts, troubleshooting. , KBA , LOD-SF-EC-TIM-REC , Recalculation , How To

Product

SAP SuccessFactors Employee Central all versions