SAP Knowledge Base Article - Public

3596606 - Interview Central - WSM Competency is not rendering sorted order in UI - Recruiting Management

Symptom

Competencies are appearing in random order in Interview Central UI, not sorted alphabetically.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Go to Recruiting > Interview Central.
  2. Click on Rating Now or Edit Rating.
  3. The interview assessment page opens.
  4. Notice that the competencies are not sorted alphabetically.

Cause

This is a known issue.

Resolution

The fix for this issue is planned to be deployed on 2H 2025 release (b2511). For release timelines, please review SAP SuccessFactors Product Release & Road Map Information.

Click on star to bookmark this article to receive updates about this issue. For more information about updates from subscribed KBAs, you can refer to the KB Article 2171560 - How to be notified of new or updated SAP Notes or KBAs.

Workaround:

The workaround only works in specific scenarios. Currently, there is no workaround for bulk updates.

1. Re-order competencies in the original job profile using Manage Data.

  1. Go to Manage Data.
  2. In the 1st dropdown, select 'Job Profile'
  3. In the 2nd dropdown, select the original job profile. (The original job profile's subModule field is empty, while RCM Job Profiles will show subModule as 'RCM'.)
  4. Click Take Action > Make Correction.
  5. Re-order competencies using the up and down arrows.

2. Create a new job requisition and it will reflect the edited order. Please note that if the competencies are edited from the Job Requisition > Job Profile page, the order may also change.

See Also

Keywords

RCM-150394, RCM, JPB, Interview Central, Competency, Order, Sequence, Alphabetical, Job Profile, Display, Random , KBA , LOD-SF-RCM-IVW , Interview Central, Interviews, Scheduling etc , LOD-SF-RCM-JOB , Job Postings & Requisitions , Problem

Product

SAP SuccessFactors Recruiting all versions