Symptom
After initiating onboarding for a candidate from Recruiting, the candidate is not visible on the onboarding dashboard.
Environment
SAP SuccessFactors Onboarding.
Reproducing the Issue
- Initiate candidate from RCM
- Search for the candidate within Onboarding Dashboard
- Can't find the candidate or candidate showing as "Unknown"
Cause
There's a field in RCM which can contain a message for future purposes, but that message has surpassed the 256 character limit, causing an error.
Resolution
To resolve this issue, ensure that there are no text fields within recruiting that have surpassed the 256 character limit. After correctin the data, go to BPE: Manage Process Tasks, filter by Job ID or Process Instance ID, and restart the task for this candidate.
For product support, please check the internal memo to get the logs.
Keywords
character, limit, onboarding, onb, obx, 2.0, recruiting, rcm, 256, inserted, value, too, large, max, length, (256), onboardee, candidate, text, EMP_JOB_INFO_T , KBA , LOD-SF-OBX-DBD , Dashboard , Problem
SAP Knowledge Base Article - Public