SAP Knowledge Base Article - Public

3596740 - "The viewer could not process an event" error is encountered when viewing/refreshing crystal reports based on ODBC data sources in CMC/BI Launchpad

Symptom

  • When viewing/refreshing crystal reports based on ODBC data sources in CMC/BI Launchpad, any of following errors is encountered:
    • The viewer could not process an event. Failed to open the connection. [report name] Details: [Database Vendor Code: XXXXX][] ---- Error code:0 [CRWEB00000119]
    • The viewer could not process an event. Your request could not be completed because a failure occurred while the report was being processed. Please contact your system administrator. [RCIRAS0546] ---- Error code:0 [CRWEB00000119]
  • The reports can be successfully viewed/refreshed in crystal reports client.

Environment

  • Crystal Server 2020
  • Windows

Reproducing the Issue

  1. Log in CMC/BI Launchpad
  2. Navigate into Folders and find a crystal report based on ODBC data source to view/refresh
  3. Any of following errors is encountered:
    • The viewer could not process an event. Failed to open the connection. [Report name] Details: [Database Vendor Code: XXXXX][] ---- Error code:0 [CRWEB00000119]
    • The viewer could not process an event. Your request could not be completed because a failure occurred while the report was being processed. Please contact your system administrator. [RCIRAS0546] ---- Error code:0 [CRWEB00000119]

Cause

  • The data sources or/and database logon information configured in Database configuration of the reports are incorrect.
  • The reports are connected to 32-bit data sources but not 64-bit data sources.

Resolution

  1. Open ODBC Data Source Administrator (64-bit) on BO server
  2. Select System DSN and click "Add..." button
  3. Create a 64-bit data source 
  4. Test connection and ensure it's successful once the configuration finished
  5. Log in CMC as the Administrator
  6. Navigate into Folders and find the report
  7. Right-click the report and open Database Configuration
  8. In "Data Sources" drop-down list, select the newly-created 64-bit data source
  9. In "When viewing and scheduling report" drop-down list, select "Use same database logon as when report is run"
  10. Under "Database logon information", select "Use original database logon information from the report"
  11. Enter the database name and user credential
  12. Click Update button to save the settings
  13. Retry to view/refresh the report in CMC/BI Launchpad

Keywords

Crystal Reports, Crystal Server 2020, Database configuration, ODBC, 64-bit Data Source, View, Refresh, Error code:0 [CRWEB00000119] , KBA , BI-BIP-CRS , SAP Crystal Server , Problem

Product

SAP Crystal Reports 2020