SAP Knowledge Base Article - Public

3597009 - Error: "The database connector 'crdb_sforce.dll' could not be loaded..." when refreshing a report based on Salesforce.com in Crystal Reports

Symptom

  • Error when refreshing reports based on Salesforce.
  • The same report connected successfully to Salesforce.com from Crystal Reports before.
  • When refreshing a report based on Salesforce in Crystal Reports, it fails with the error:

    "Failed to load database information.
     Details: The database connector 'crdb_sforce.dll' could not be loaded.
     The correct version of the database client for this database type might not be installed."

Environment

  • SAP Crystal Reports 2020
  • SAP Crystal Reports 2025
       
  • Salesforce.com

Reproducing the Issue

  1. In Crystal Reports, open a report connecting to Salesforce.com
  2. Refresh the report.
  3. It fails with the error:
      
    "Failed to load database information.
     Details: The database connector 'crdb_sforce.dll' could not be loaded..."


Cause

  • Salesforce connection has been removed from Support Pack 04 of Crystal Reports 2020.
  • Crystal Reports Salesforce.com driver (OEM) is no longer supported by the OEM vendor starting from December 2023, and therefore this is why the Salesforce connection has been removed from Support Pack 04.
         
  • For reference, see Crystal Reports 2020 supported platforms document found in the SAP Knowledge Base Article:
       
    2859510 - Supported Platforms documents for Crystal Reports

Resolution

  • To connect to Salesforce, use a third party ODBC / JDBC driver.

Keywords

CR, sforce, saleforce, salesforce.com , KBA , BI-RA-CR , Crystal Reports designer or Business View Manager , Problem

Product

SAP Crystal Reports 2020 ; SAP Crystal Reports 2025