Symptom
- An error occurs when attempting to open an Excel file connected to BPC via the EPM Add-in.
The error message states: "Addin returned an error. Check logfile of the addin!" - The issue persists even when the file is opened using the launcher BiOfficeLauncher. However, when the file is opened using EPMlauncher.Office, it works as expected.
Environment
- EPM Excel Client
- SAP Analysis Office 2.8 SP25 64bit
- SAP-BPC 2021
- Windows 11 Enterprise
- Excel 365 MSO
Reproducing the Issue
- Access BPC web
- Click on the gear wheel on the right corner to open the link to the Excel file.
- Click on the link to open the Excel file via EPM Add-in.
- Observe the error message: "Addin returned an error. Check logfile of the addin!"
Cause
- The issue is caused by a configuration problem where the system uses the launcher BiOfficeLauncher to open the Excel file instead of the EPMlauncher.Office.
Resolution
Verify the program associated with the .SAPAOX file.
it calls for the epm launcher when a non-MS browser is being used.
See: Installing EPM Add-in for Microsoft Office (standalone) | SAP Help Portal at step 11
3093139 - How to launch the EPM Add-in automatically from the BPC Web page when using Microsoft Edge
See Also
there can be 32/64 issues as noted in:
2454020 - Cannot launch EPM Add-in directly while using Firefox
Keywords
BPC, EPM Add-in, Excel file, error, logfile, EPMlauncher.Office, .SAPAOX file, configuration, EPMLauncher.exe, BiOfficeLauncher.exe. , KBA , EPM-XLS , EPM Excel Client , Problem
Product
SAP Analysis for Microsoft Office all versions