Symptom
After a third-party system outage, customer needs to trigger integration of an object (e.g.: Sales Order) massively via Data Workbench.
Environment
SAP Cloud for Customer
Reproducing the Issue
Example of a manual process that needs to be replaced by an automatic one:
- Open a pending order.
- Hit 'finish'.
Customer has a huge amount of orders in this scenario and wants an automatic way to do so.
Cause
The current release of C4C does not support the automatic triggering of a call to finish sales orders from DWB or via Odata services.
This implies that the mass replication of C4C sales orders to ERP system cannot be achieved through DWB or Odata services.
The development team is aware that there may be instances where a third-party system outage requires the bulk replication of sales orders that have not been replicated to the S4 system. At present, the most effective method to handle these pending C4C orders is to manually replicate them to the S4 system.
Resolution
Please share your request in the collaboration forum to suggest new features for future releases. It is possible to utilize the Customer Influence Site to express your thoughts on adding new features to future releases of SAP Cloud for Customer. This platform also provides complete transparency about the status of all submitted ideas
Keywords
Trigger; hit; integration; Sales Order; massively; Data Workbench; mass; replication; third-party; outage; bulk; replication. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , Problem