Symptom
- When I9 Reverification is completed and signed, the Corporate Representative is unable to create an E-verify case for the employee.
- Error Message: The new hire's existing Form I-9 is not completed. You must complete the existing Form I-9 process before you can manually initiate E-Verify.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login to the instance as the Corporate Representative
- Go to "Create E-Verify Case"
- Select the employee
- After clicking submit, the error is received.
Cause
Issue has been identified as a defect.
- I9 Reverification process completed both steps - Section 3 Submission and Signature, however the status of Compliance Process is still in 'Started' status
- Manual E-Verify check includes if user have Compliance Process in 'Started' status and if I9UserData 'DocumentId' field is empty.
- Both conditions are not met which caused described the issue.
- Need to change the behavior to cover such scenario - Manual E-Verify after I9 Reverification.
Resolution
WORKAROUND:
- Set the I9 Verification Compliance Process of the affected candidate status to Completed
- Reset the field 'documentId' in I-9 User Data object for the affected employee. The value should be empty
PERMANENT FIX: OBX-38482
- The Engineering Team has introduced a code-fix and tentatively targets the deployment on 2H 2505 (b2511). No patch plans at this time.
- Continue to follow the above workaround until the fix is deployed.
- NOTE: Roadmap disclaimer applies.
Keywords
OBX-38482, I9 Verification, Manual E-Verify, EVF, I9, EVerify, I-9 User Data, I9userData, Compliance, "The new hire's existing Form I-9 is not completed. You must complete the existing Form I-9 process before you can manually initiate E-Verify.", Onboarding, OBX, ONB2, ONB , KBA , LOD-SF-OBX-EVF , Everify , LOD-SF-OBX-I9 , i9 Compliance Form , Bug Filed
Product
SAP SuccessFactors Onboarding 2411