SAP Knowledge Base Article - Public

3597645 - Duplicate Email and Telephone Tags for Accounts in Sales Order Query Web Service Response

Symptom

When querying for Sales Orders using the QuerySalesOrderIn Web Service, you notice that for certain Sales Orders, there are duplicate entries for the Telephone and Email address tags in the response, while there are no duplicates present in the Account itself.

Environment

SAP Business ByDesign

Reproducing the Issue

Query for a Sales Order using a sample payload such as: 

<SalesOrderSelectionByElements>
            <SelectionByID>
               <InclusionExclusionCode>I</InclusionExclusionCode>
               <IntervalBoundaryTypeCode>1</IntervalBoundaryTypeCode>
               <LowerBoundaryID>ABC</LowerBoundaryID>
            </SelectionByID>
         </SalesOrderSelectionByElements>

(Where ABC represents the Sales Order ID).

In the Response for some Sales Orders, there are duplicate entries for tags <Email> and <Telephone> which are not duplicate in the Account.

Cause

This issue can happen when the Account originally contained multiple email IDs and other maintained data. The duplicate values in the Web Service Response can then happen due to: 

-The Sales Order being copied from an existing one that contained the Address.
-The duplicate Address having been deleted from the Account after the Sales Order was created.

Resolution

In order to avoid this issue, use new Sales Orders which have not been copied from existing Sales Orders.

See Also

Sales Order, Web Service, Query Sales Orders, Webservice, duplicate, copied, Address, Email, Telephone, Tags

Keywords

KBA , AP-SLO-SO , Sales Order , How To

Product

SAP Business ByDesign all versions