SAP Knowledge Base Article - Public

3597830 - Unable to Complete UK Starter Checklist Compliance Form - Onboarding

Symptom

  • Unable to complete UK Starter Checklist Form  due to address fields being greyed out.
  • The issue occurs when the user does not have a P45 form and selects "No" for P45 on the form.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Navigate to the UK starter checklist compliance form.
  2. Select "No" for P45.
  3. Observe that fields have become greyed out and uneditable, preventing the form from being completed.

Cause

  • The issue arises due to the candidate using a Temporary address instead of a Home address.
  • The UK Starter Checklist form only takes information from the Home Address field. 

Disclaimer:

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental." 

Resolution

  1. Ensure that the candidate maintains a Home Address during the Onboarding process, either during New Hire Data Review or Personal Data Collection.
  2. Avoid using a Temporary address as this information will not be pulled onto the form.
  3. Implement a validation rule to avoid this issue in the future.
  4. Refer to [Scenario 12] on the SAP blog for an example of a validation rule.

See Also

Human Capital Management Blogs by SAP

Keywords

SAP SuccessFactors, Onboarding, UK starter checklist, compliance form. , KBA , LOD-SF-OBX-FRM , Compliance 2.0 Country Forms (except i9&EV) , Problem

Product

SAP SuccessFactors Onboarding