Symptom
- The service date field is not functioning as expected for rehire cases in SAP SuccessFactors Employee Central.
- A business rule has been implemented for this field during Hire and Rehire cases.
- While the rule works correctly for Hire cases, it does not function as expected for Rehire cases.
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- Navigate to the Employee Central module in SAP SuccessFactors.
- Proceed with a rehire case.
- Observe that the 'Service Date' field does not get populated with the value from the other field as expected based on the business rule.
Cause
The issue is caused by a malfunction in the business rule 'ECF_Service_Date' which is supposed to derive the 'Service Date' from another field during rehire cases.
Resolution
Behavior is caused by a code issue. The code fix is checked in with ECT-252136 and would be available with the 2511 release.
Keywords
SAP SuccessFactors, Employee Central, Service Date, Rehire Cases, Business Rule, Start Date, ECT-252136, 2511 Release. , KBA , LOD-SF-EC-HIR-RIE , Rehire Inactive Employee , Known Error
Product
SAP SuccessFactors Employee Central all versions ; SAP SuccessFactors HCM Suite all versions