SAP Knowledge Base Article - Public

3597943 - Assessment Integration - Initiation Failed due to Can't extract a '"access_token"\s*:\s*"(\S*?)"' - Recruiting Management

Symptom

  • Assessment Status shows Initiation Failed.
  • Event Notification Audit Log shows an Exception=[Response body is incorrect. Can't extract a '"access_token"\s*:\s*"(\S*?)"' from this: '<!DOCTYPE html>]

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Initiate assessment for the candidate.
  2. Observe that the assessment status shows 'Initiation Failed'.
  3. Go to Event Notification Audit Log to review the log for 'rcm_assessment_alert_V2'
  4. Observe an error in the response "Exception=[Response body is incorrect. Can't extract a '"access_token"\s*:\s*"(\S*?)"' from this: '<!DOCTYPE html>]"

Cause

The Token Endpoint configured for the 'CLIENT_CREDENTIALS' authentication method is incorrect.

Resolution

  1. Go to Admin Center >> Event Notification Subscription >> External Event.
  2. Edit the rcm_assessment_alert_v2 event.
  3. Enter the correct Token Endpoint.

The Token Endpoint URL typically ends with /oauth/token. Please confirm with the vendor for the correct endpoint URL.

See Also

KBA 3302755 - What is the Event Notification Subscription authentication method for assessments using OAuth 2.0? - Recruiting Management

Keywords

RCM, Assessment, Error, Token, Initiation Failed, OAuth 2.0 , KBA , LOD-SF-RCM-ASI , Assessment Integration , Problem

Product

SAP SuccessFactors Recruiting all versions