SAP Knowledge Base Article - Public

3597988 - "Looks like something went wrong" appears when a candidate tries to view Online Offer Letter / My Offers - Recruiting Management

Symptom

  • Error occurs when trying to accept online offer letter or DocuSign eSignature offer letter.
    • Looks like something went wrong
    • Please try again. If the issue persists, contact your system administrator.
  • The candidate cannot view the offer letter on My Offers page.

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Open the link in the offer letter notification.
  2. Log in to the candidate profile.
  3. An error "Looks like something went wrong" appears.

Cause

 A candidate can have multiple profiles in the system. The candidate may have not logged in with the correct profile to view the offer letter.

Resolution

Please verify the email address / username the candidate used to log in. 

1. Navigate to the candidate's application in Recruiting and check the email address below the candidate name. This is the Contact Email of the candidate.

2. Check the Primary Email (Username) of the candidate using the 'Manage Duplicate Candidates' tool.

  1. Go to Admin Center > Manage Duplicate Candidates > 'Manually Merge Duplicate Candidates' tab.
  2. Select 'External Candidate'.
  3. Select 'Contact Email'.
  4. Type the email address and search.

The 'Primary Email' displayed in the results is the candidate's login username. If multiple profiles appear, click 'View Profile' and check the Jobs Applied section to identify the profile used to apply to the job requisition. 

The candidate needs to use this 'Primary Email' to reset password and log in to the career site.

Manage duplicate candidates_Primary email.png

See Also

Keywords

RCM, Candidate Profile, Offer Letter, DocuSign, Career, My Offers, Error, Access, Accept, Sign in , KBA , LOD-SF-RCM-CAO , Candidate Offers, Offer Letters , Problem

Product

SAP SuccessFactors Recruiting all versions