Symptom
- When clicking the Check Configuration button (System > Administration > Data Source Configuration", you may get one of the following errors:
- "Failed to call SAP Analytics Cloud Agent. Please contact your administrator to ensure that SAP Analytics Cloud Agent is running, configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector"
- Failed to call SAP Analytics Cloud agent and refer to the system monitor trace for details. Please contact your administrator to ensure that SAP Analytics Cloud agent is running, configured correctly and is reachable from the SAP Cloud Platform Cloud Connector.
- "Failed to call SAP Analytics Cloud agent. Please contact your administrator to ensure that SAP Analytics Cloud agent is running, is configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector. HTTP Status: 403; PATH: /deplymentInfo"
- "Failed to call SAP Analytics Cloud agent. Please contact your administrator to ensure that SAP Analytics Cloud agent is running, is configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector. HTTP Status: 401; PATH: /deplymentInfo"
- "Please verify your configuration settings to ensure all entered values are correct. If verified, please contact SAP Support regarding the configuration issue."
- You may also observe the following error from either system trace monitor or Chrome Network trace (HAR file)
- "Please verify SAP Cloud Platform Cloud Connector connection status; and check the Cloud Connector logs to see if the network firewall is blocking external access. If connected, please contact SAP Support regarding backend connectivity issue. HTTP Status: 503, Action: Check version"
Environment
- SAP Analytics Cloud, Enterprise Edition
- SAP Analytics Cloud agent (SAC Agent)
- SAP Cloud Platform Cloud Connector (SCC)
Reproducing the Issue
- Log on to SAC tenant with an administrator account.
- From the side navigation, choose System > Administration > Data Source Configuration.
- In the On-Premise Data Sources section, select one existing Location or click Add a new location by providing the following information in the pop-up:
- Enter Location ID
- Make sure Enable Agent is set to ON
- Host: Virtual host specified during the SAP Analytics Cloud configuration
- Port: Virtual port specified during the SAP Analytics Cloud configuration
- Username: Agent user name specified in tomcat-users.xml file
- Password: Agent password specified in tomcat-users.xml file
- Click Check Configuration.
Resolution
Prerequisites
To configure the SAP Analytics Cloud agent settings in SAP Analytics Cloud, the following prerequisites (See Help Guide) must be meet in advance:
- The Cloud Connector is installed and Configured correctly
- The SAP Analytics Cloud agent is installed and Configured correctly
General Steps
- Configure SAC Subaccount in the SAP Cloud Platform Cloud Connector.
- Refer to 2397165 - How do I connect the SAP Cloud Connector (SCC) to SAP Analytics Cloud (SAC)?
- Installing the SAP Analytics Cloud Agent.
- Configure access control (System Mapping and Accessible Resource) in the SAP Cloud Platform Cloud Connector.
Possible Cause
So the issue could be caused by several different reasons when misconfiguring the SAP Analytics Cloud Agent and SAP Cloud Connector:
Issue with Cloud Connector
-
Subaccount related
- Incorrect Subaccount: 2740025 - Failed to call SAP Analytics Cloud agent... ensure that SAP Analytics Cloud agent is running... as is reachable from the SAP Cloud Platform Cloud Connector
- Expired subaccount certificate: 3589325 - Error: "SAP Cloud Agent is not configured correctly. Please check your configuration settings." occurs while checking the Location ID in SAP Analytics Cloud.
-
Location ID related
- The "Location ID" value in SAP Analytics Cloud does not match the Location ID of the corresponding subaccount configured in the SAP CP Cloud Connector:
2774864 - "Failed to call SAP Analytics Cloud Agent..." or "Please verify your configuration settings..." error when checking the datasource configuration in SAP Analytics Cloud (SAC)
- The "Location ID" value in SAP Analytics Cloud does not match the Location ID of the corresponding subaccount configured in the SAP CP Cloud Connector:
-
System Mapping related
- The internal host name and port has been used in SAC: 3424799 - "Failed to call SAP Analytics Cloud Agent. Please contact your administrator to ensure that SAP Analytics Cloud Agent is running, configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector" error in SAP Analytics Cloud.
- Special character such as an underscore (_) or a dot (.) in the virtual host name: 2806384 - Error "Failed to call SAP Analytics Cloud Agent. Please contact your administrator to ensure that SAP Analytics Cloud Agent is running, configured correctly, and is reachable from the SAP Cloud Platform Cloud Connector"
- Network blocking between SCC and SAC Agent: 2600206 - Failed to call SAP Analytics Cloud agent in SAP Analytics Cloud (SAC)
-
Accessible Resource related
-
Other configuration related
- Trusted Applications configuration: 2508215 - "Failed to call SAP Analytics Cloud agent..." error in SAP Analytics Cloud after checking the configuration in datasource configuration
Issue with SAP Analytics Cloud agent
-
Tomcat User Credential related
-
Verify & Testing
- 3589224 - How to verify the version of SAP Analytics Cloud Agent ?
Troubleshooting Reference
See Also
- 2902697 - SAP Analytics Cloud agent - Frequently Asked Questions and Additional Information
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support
Your feedback is important to help us improve our knowledge base.
Keywords
acquire, acquisition, import, importing, datasource, onpremise, Cloud for Analytics, C4P, Cloud 4 Planning, HCP, C4A, BOC, SAP BusinessObjects Cloud, bobj , SAP Analytics Cloud, SCC, HCC, SAC, SAP CP CC, SCPCC, SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics, agent, location, data source, subaccount , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Problem