Symptom
When trying to cancel E-Verify cases which have no case number in Create E-Verify Cases page, a pop-up shows that cancellation is succeeded but the case is still open.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Go to Manage Data > E-Verify Data
- Search with employee's user id > find an open E-Verify case in status e.g. "CREATE & SUBMIT" without case number
- Go to Create E-Verify Case > search the employee's name
- Open the E-Verify case > only "Cancel E-Verify Process" button is available and no "Resolve Case" button
- Click on "Cancel E-Verify Process" > see pop-up message that cancellation is successful
- However, the E-Verify case is still open
Cause
Compliance Process Status is "Compliance process completed" which prevents the E-Verify cancellation status from being updated.
- (For SAP Support only) Backend log: [CancelEVerifyProcessImpl] EVerify ComplianceProcess {} is already completed(*ComplianceProcessId*)
Resolution
- Go to Manage Data > Compliance Process > search for user id / relative compliance process id
- Select Take Action > Make Correction
- Set the Compliance Process Status to "Compliance process started" > save
- Go to Create E-Verify Case and cancel the E-Verify case again
Please note, once the latest E-Very is cancelled, the Compliance Process Status will become cancelled.
*In case see error "activityID is required" in Step 3:
- For customer: kindly create a support ticket to request for a script with this KBA attached
- For SAP Support: kindly check details in internal memo
Keywords
SAP SuccessFactors, Onboarding, E-Verify, Duplicate Cases, Compliance Process Status, Cancel E-Verify Process, Resolve Case, CREATE & SUBMIT, CLOSED , KBA , LOD-SF-OBX-EVF , Everify , Problem
SAP Knowledge Base Article - Public