Symptom
You are replicating Utilities Technical Objects (service interface :UtilitiesTechnicalObjectReplicationIn) from ISU to C4C system and message fails in C4C Web Service Message Monitoring with error: CX_AP_DATA_REPL_MAPPING_ABORT:"An exception was raised"[CL_AP_DATA_REPL_MAPPING_HELPERCM002:18]
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Administrator work centre.
- Go to the Web Service Message Monitoring view.
- Search for relevant message ID.
- See that incoming message for 'UtilitiesTechnicalObjectReplicationIn' service interface fails with error: CX_AP_DATA_REPL_MAPPING_ABORT:"An exception was raised"[CL_AP_DATA_REPL_MAPPING_HELPERCM002:18]
Cause
The error is due to the two communication systems which were created with the same IDoc Logical System ID. Hence, messages are failing.
Resolution
Remove the communication system (which is not in use) and restart failed messages.
See Also
Keywords
CX_AP_DATA_REPL_MAPPING_ABORT , logical system , communication system , KBA , LOD-CRM-IND-UTL , Utilities , Problem