Symptom
- System accepts 123456789 even if there's an existing 123-456-789 phone number.
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Create a Candidate Profile with phone number 123456789
- Create another Candidate Profile with phone number 123-456-789
Cause
This is an expected behavior of the system. If the formatting of phone numbers doesn’t match, the system doesn’t recognize the numbers as duplicates. For example, the system wouldn’t identify the same phone number with and without hyphens as a duplicate.
Resolution
If you wish for the feature be considered by the Product Management Team to be added in Future Release, please submit an enhancement request as documented on the KBA 2090228 - How to submit enhancement ideas for SAP SuccessFactors Products.
See Also
Keywords
SAP SuccessFactors, Recruiting, Candidate Management, Phone Number Validation, Duplicate Candidates, Format Issue, Dash, Phone Number. , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem