Symptom
When trying to delete a business rule triggers the error: You can’t delete this rule because the scenario this rule is assigned to is not active in your system.
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Access Configure business rule
- Try to delete it
- Triggers the error message "You can’t delete this rule because the scenario this rule is assigned to is not active in your system."
Cause
The rule is being deleted outside manage data screen.
Resolution
Please delete the business rule or make corrections to the business rule as described below:
- From Admin Tools / Admin Center => Navigate to "Manage Data"
- In the first drop down, select "Rule".
- In the second drop down, search for the rule you want to make corrections or Delete Permanently
- Once the rule is loaded, click on "Permanently delete this record" to delete the Rule ( or ) make corrections if you want to make changes to the rule.
It would be better if you delete the rule and recreate it again if the rule is currently not in use in the system. However, make sure the definition of the rule is correct.
Keywords
obx, onb, onboarding, rule, business, deletion, delete, permanently, erase , KBA , LOD-SF-OBX , Onboarding 2.0 , How To