SAP Knowledge Base Article - Public

3598731 - National ID API query does not match Employee Profile - OData API

Symptom

You are using OData API to query the PerNationalId entity (National ID Information).

In the API response, for a user you may find multiple records (for different countries).

But when you check Employee Profile for this user, one or more records are missing in the UI and it doesn't match API response.

Environment

SAP SuccessFactors HCM

  • OData API

Cause

It's because your login user has the "National ID (Restricted to only country/region of legal entity)" permission.

This permission will restrict to view the National ID only from this user's Legal Entity country.

Your API user does not has this permission, or it has the Admin Permission "Employee Central HRIS OData API (read-only)".

Resolution

It's expected according to the permission settings. You could login with another user (without the restricted permission) to verify the Employee Profile result.

If you also would like to restrict API user's view permission, you could refer to 2316798 - How to restrict API access to specific Employee Central Entities and Fields

See Also

2316798 - How to restrict API access to specific Employee Central Entities and Fields

Keywords

SFAPI, PerNationalId, data not displaying, RBP, API access, disappear, hide, limit , KBA , LOD-SF-INT-EC , Employee Central SFAPI & OData Entities , LOD-SF-INT-ODATA , OData API Framework , Problem

Product

SAP SuccessFactors HCM Core 2505