Symptom
When performing batch determination for a production/process order that already has batches assigned, an Open Quantity remains to be assigned. However, after performing the batch determination and reviewing the result, the open quantity is not allocated to any batch.
Environment
SAP S/4HANA Cloud Public Edition.
Reproducing the Issue
- Go to a Production Order/Process Order app.
- Components/Material list tab.
- Select the component with a batch assigned and open quantity.
- Perform batch determination.
- Open quantity is not assigned.
Cause
Batch determination was already carried out previously. When you perform a new batch determination, the system retains the already assigned batches. For these existing batches, the system only checks whether the originally assigned quantity is still available. If not, the quantity is adjusted accordingly - but it will not be increased automatically.
Resolution
To update or reassign the batch quantities, the process must be done manually.
Follow these steps:
- Go to Change Production/Process Order.
- Navigate to the Components tab.
- Select the component material with a batch split.
- Click on Batch Determination.
- From the Edit menu, choose Reset Quantities (alternatively, you can use Distribute Quantities).
- Click Copy to apply the changes.
Note: Resetting the quantities will delete the previous batch split. Batch determination can then be performed again as usual.
Keywords
SAP S/4HANA Cloud Public Edition, Batch Determination, Production Order, Component, Storage Location, Batch Number, Leftover Quantity, Open Quantity, wrong, , KBA , LO-BM-BD-2CL , Batch Determination (Public Cloud) , Problem