Symptom
- An error is encountered when attempting to log into the SAP SuccessFactors Mobile Application while switching between test and production instance.
- The error message displayed is "Profile not available on this device. You can only add profiles for users from the same company as the owner."
Environment
SAP SuccessFactors Mobile
Reproducing the Issue
- Attempt to log into a different environment in the SAP SuccessFactors Mobile Application while another profile is already active.
- Encounter the error message "Profile not available on this device. You can only add profiles for users from the same company as the owner."
Cause
The underlying authentication system/flow that is required to use Joule and other future, next gen features doesn’t support mixed instances in Multi-Profile Mode, so that ability was removed in Feb 2025.
Multi-Profile Mode (using profiles from the same instance/environment) still very much works, and users can “switch” instances/environments by deactivating as a Prod user and reactivating as a Preview user
Resolution
- Error is an expected behavior due to a patch deployed on February 2025 to prevent switching between test and production environments when using multiple profiles.
- Deactivate / reactivate the app or use a different device to access the system. If you have MDM, to deactivate you need to:
> Tap Deactivate on the Settings screen.
> When the activation process begins, manually stop the flow. (If not stopped, it will log in to the production instance.)
> This interruption enables connection to another company - in this customer's case, the Preview environment. - Refer to the following document for more information: Enabling Mobile App for Multiple Profiles
See Also
Keywords
SAP SuccessFactors, Mobile Application, Login Error, Development System, Security Patch, Multiple Profiles, Profile not available, Profile not available on this device, mobile, activate, The user can't be added on this device, You can only add profiles for users from the same company as the Owner , KBA , LOD-SF-PLT-MOB , Mobile Issues , Problem
SAP Knowledge Base Article - Public