Symptom
Although the ID mapping of the Business Partner is correctly maintained on the C4C, the inbound web service is mapped with a wrong Business Partner ID then, the data is updated with incorrect values.
Environment
- SAP Cloud for Customer
- SAP S/4HANA
Cause
The following fields are not present in the incoming payload.
- /ns0:BusinessPartnerSUITEBulkReplicateRequest/BusinessPartnerSUITEReplicateRequestMessage/BusinessPartner/ReceiverInternalID
- /ns0:BusinessPartnerSUITEBulkReplicateRequest/BusinessPartnerSUITEReplicateRequestMessage/BusinessPartner/Customer/ReceiverInternalID
Then, the issue and the cause of the issue seems to be related to the Key Mapping in S/4HANA side.
Resolution
Therefore, please check the t-code MDG_ANALYSE_IDM and also the SAP Blog Post Key Mapping in Master Data Management.
Then, maintain the Key mapping in S4 according to the ID Mapping for Integration in C4C.
Keywords
C4C, Cloud for Customer, External ID, Account, Business Partner, ReceiverInternalID, , KBA , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To
SAP Knowledge Base Article - Public