Symptom
When opening the actions menu on a quote, user is not able to see the "Comment" action available.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Open a Quote
- Add a product
- Click on the action for this product
- "Comment" Action is not visible.
Cause
"Comment" action has not been properly configured, thus not being visible.
Resolution
- "Comment" is added through Layout customization
- UserDescription is the name of the Field/Column that should be set
- For Quote 1.0:
- In Quote Layout Permissions find field UserDescription and configure it's visibility
- In UI Design - Quote Layout find field UserDescription and add it to the Quote layout
- In cart field administration make field UserDescription editable.
- For Quote 2.0:
- In Field, Calculations, Layout, got to Field Editability, find UserDescription field and make it editable
- In Layout add UserDescription field
- Configure it's permission under Layout Permission.
Keywords
Comment, Item Action, Quote, Line Item, Item, Product, CPQ , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , How To
Product
SAP CPQ 2024