Symptom
You are using the Obsolete Business Partner removal runs to remove data from the system. However when checking the data removal run created for the business partners which were selected by the Obsolete Removal run, you can see the status of the removal as Removal Failed.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Data Protection and Privacy work center.
- Enter the Common Tasks view.
- Click on Administer Obsolete Business Partner Removal Runs.
- Select the run created.
- On the panel below, click on a log ID to open it.
- Navigate to the Results tab.
Here it is possible to see the data removal runs created for each business partner which is to be removed by the criteria. - Navigate to the Data Protection and Privacy work center.
- Enter the Common Tasks view.
- Click on Administer Data Removal Runs.
- Search for the ID picked up on step 6.
Here it is possible to see that the Removal Failed column displays "Yes", and there are no further details on the application log.
Cause
The Obsolete Business Partner Removal Run is generating a large amount of data removal runs, and the system is not being able to finish the data removals fast enough, causing an overload.
Resolution
In case there is a large amount of data to be removed on a daily basis (above 2000 records), it is recommended to schedule the Obsolete Business Partner Removal Run to be executed with a larger interval of time, such as once per week or every 10 days.
Keywords
Removal, Deletion, Personal Data , KBA , AP-RC-ILM , ByD,C4C,Travel: Information Lifecycle Management , Problem