Symptom
- A completion event was deleted from a user's record. However, when downloading a Canvas report in Analytics Reporting, this completion is still shown for the user.
- When going to Learning Administration > People > Users > user record > Assigned items tab > filtering by Completed items, the course appears with a completion date. However, in the Completed Items tab, the course is not there.
Environment
SAP SuccessFactors Learning
Cause
-
If the item is assigned to the user through a program and marked as completed by admin, it will update the completion date and status in the PA_STUD_CPNT table (learning plan table). When an admin removes the completed item from this user, this will remove the item from the user's completed items tab (PA_CPNT_EVTHST table), but the program will remain marked as completed, and the completion date and status, which were updated in the PA_STUD_CPNT table, will remain intact. If the Canvas report is fetching the data from PA_STUD_CPNT table, this is expected behavior.
- The admin deleted the item history, specifically the item completion. This explains the discrepancy in between the Assigned Items and the Completed Items tabs:
- The Assigned tab's completion date fetches from the PA_STUD_CPNT table;
- The Completed tab's completion date fetches from the PA_CPNT_EVTHST table.
- When the admin updates/deletes the completion date for an item, it is only reflected in the PA_CPNT_EVTHST table. This behavior occurs because once the program is marked as completed, any subsequent changes to the program items are not taken into consideration. This is why the report is pulling the current data.
Resolution
This is expected behavior.
Keywords
canvas, report, learning, lms, PA_STUD_CPNT, PA_CPNT_EVTHST, assigned items, completed items, remove completion, deleted, record, event, program , KBA , LOD-SF-LMS-REP , Reporting Data , LOD-SF-LMS-USR , User Entity , Problem