Symptom
The Task "Sales Order XYZ Approved" appears in the Unassigned Tasks and is not automatically assigned to a user (XYZ represents the Sales Order ID).
Environment
SAP Business ByDesign
Reproducing the Issue
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Go to the Application and User Management work center.
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Select the Business Task Management view.
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Select Unassigned Items in the drop down list.
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The following Task appears and is not assigned automatically to the user: Sales Order XYZ Approved
Cause
These tasks (Task Type CRM_SO_NTF_APPROVED) are created and sent to the Employee Responsible of the Sales Order, once the Sales Order was approved.
The system can only assign the Task to the user, if the user of the Employee Responsible has read and write access rights to the Sales Orders work center view.
Resolution
To solve the issue, you need to ensure that the users have read and write access to the Sales Orders view.
- Go to the Application and User Management work center.
- Select the Business Users view.
- Select the user maintained for the Employee Responsible in Sales Order XYZ.
- Click on Edit -> Access Rights.
- Select the Access Restrictions tab.
- Select Work Center View ID CRM_SALESORDERS.
- You can see that the user has either no Read Access, no Write Access or both.
- Assign the user Read and Write access.
See Also
Sales Order, Approval, Task, Employee Responsible, authorization, not authorized, access, CRM_SO_NTF_APPROVED
Keywords
Unassigned Sales Order, Approval, Task Distribution, Business Task Management, Access Rights, MMA_SALES, TERR_SALES_MGR, CC_HOME, Work Center View. , KBA , AP-SLO-SO , Sales Order , Problem