Symptom
LMS report was imported to report center, however when trying to run or edit it it gives one of the following error message:
- Error loading Live Data Connection. Please contact your administrator.
- Cannot connect to the model. Please verify that you have set the correct connection details for this model, then try again.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
- SAP SuccessFactors HCM Suite
- SAP SuccessFactors People Analytics
Reproducing the Issue
- Import an LMS report to Report Center
- Try to run or edit it, error message pops up
Cause
One of the reason this error message can pop up is that LMS is not enabled for the instance, or the enablement failed.
Resolution
To check if LMS is enabled, try to create a new story report. If there is an option to choose between SAPSFSREP and SAPSFSFLMS, then LMS is enabled.
If the dropdown menu is not appearing, check if LMS was enabled but failed in the instance:
- In Provisioning, go to Manage Scheduled Jobs and then Monitor Jobs. (Please note that only Product Support and Implementation Partners have access to Provisioning.)
- In Job Type, select "Configuration Job for Stories in People Analytics"
- Look for a record called SACUpgradeCenterForLMS. If there is no record with this name, then LMS was not enabled.
If there is a record with this name, but the status is Failed, then the enablement failed. In this case, raise a ticket to LOD-SF-LMS.
LMS has to be enabled in order for the imported LMS reports to work:
- In Provisioning, go to Configurations for Stories in People Analytics
- Look for Enable SAC in LMS and click on Enable
- Go back to Provisioning
- Go to Manage Scheduled Jobs > Monitor Jobs
- Look for SACUpgradeCenterForLMS and wait until the status change to Completed
Keywords
LMS, Story Report LMS, LMS Error, LMS Fail, Enable LMS, Imported Report. , KBA , LOD-SF-ANA-SAC-DAM , Data Modelling - Module & Entity Data Issues , Problem