Symptom
The system is not triggering the Step Due or Overdue notifications. The email is not being launched.
Environment
SAP SuccessFactors Performance & Goals
Reproducing the Issue
- In Change Email Notification Setting: User email is enabled as a valid email.
- In the Provisioning: Send 360 Step Due Notification and Send 360 Step Late Notification were created, with daily reocurrence. And are running normal every day.
- In Form Template Setting: Default Due Notification Date (in days) is set to a valid integer number days, for example "2".
- In E-Mail Notification Templates Setting: Due Step and Due Late Notification is enabled.
- In Manage Route Map: The Due Date of the step is set.
- User then launchs the form, and even with all the configurations right, the email is not triggered.
Cause
The issue can be caused by the "Default Due Notification Date (in days)" field being set to an excessively large value or an invalid value (for example, 999999999) in several other form templates. This invalid configuration caused the Step Due and Overdue Notification job to throw an exception, preventing it from running successfully.
Resolution
To resolve the issue, please navigate to Admin Center > Form Template Settings, review all enabled form template, and update the Default Due Notification Date (in days) to a valid and reasonable number, such as 7 days.
See Also
- 2559363 - Document Due/Late Notification and Step Due/Over Due Notification - Performance Management
Keywords
Step, Due, Over, Overdue, Step due, Notification, Notification, trigger, launch, email, PM, Form, Forms , KBA , LOD-SF-PM-EML , Emails and Notifications , Problem