Symptom
Even with the Automation to terminate benefits correctly configured according the implementation Guide, and the event being successfully ran and completed, existing enrollment is not being terminated with the message: "No existing enrollment record was found for this benefit. Please try again."
Environment
SAP SuccessFactors Employee Central
Reproducing the Issue
- After the termination event was triggered correctly, go to the Benefit Event Log affected;
- In Benefit Event Log Details, see that the status is "Success";
- Click in Details;
- In "Result of Benefit Processing" see the message: “No existing enrollment record was found for this benefit. Please try again.”;
- But if you check the existing enrollments for this employee, you will see that there is still one active enrollment for this benefit.
Cause
Data issue with duplicated enrollments for the same benefit, for the affected employee. The duplicated enrollment will not be visible via UI, so it's necessary to export the Benefit Enrollment records and searching for worker ID.
Resolution
To correct this, the wrong enrollment need to be delete from the system via import using the DELETE operation (2236017), and then retrigger the event for the correct ones to be delimited.
See Also
Automating Benefits Termination
2236017 - Mass Deletion of MDF Data via Import.
Keywords
"No existing enrollment record was found for this benefit."; BENEFITS_INVALID_PREVIOUS_ENROLLMENT_ID; No enrollments found for the user with the specified previousEnrollmentId , Termination event; existing enrollment not terminated with automation; "Result of Benefit Processing" , KBA , LOD-SF-EC-GBF , Global Benefits , Problem