Symptom
- You can see the following error in your Catalina logs: java.io.IOException: Too many open files;
- Your Agent/Tomcat URL becomes inaccessible: <tomcat_host:port> and tomcat_host:port/C4A_AGENT/deploymentInfo
- Restarting your Tomcat solves the issue.
Environment
- Apache Tomcat 9
- SAP Cloud Agent
Reproducing the Issue
The issue happens whenever Tomcat tries to open more files than defined by the ulimit parameter.
Cause
The ulimit parameter on Linux machines is used to control the system's resource limits for processes running on the machine. It specifies the maximum resources that a user or process can use, which helps prevent a single process from consuming all the system's resources and potentially causing instability.
Resolution
To resolve this error, you need to increase the file descriptor limits (the ulimit parameter) on your Linux system. This will allow Tomcat to open more files simultaneously, which can help avoid the error you're seeing.
To do this, you can set a higher ulimit value for the entire Linux system by editing the /etc/security/limits.conf file.
Alternatively, you can edit the ulimit for the Tomcat service user only. This approach is ideal if you want to avoid changing system-wide settings. You can do this by editing the Tomcat systemd service configuration file:
- Usually located in /etc/systemd/system/ or /lib/systemd/system/: sudo nano /etc/systemd/system/tomcat.service;
- Under the Service section, add: LimitNOFILE=65536;
- Reload systemd to apply the changes: sudo systemctl daemon-reload;
- Restart Tomcat: sudo systemctl restart tomcat.
ulimit - How do I increase the open files limit for a non-root user? - Ask Ubuntu
** Important caveats: **
- The ulimit parameter is only applicable to Linux Operational Systems;
- The steps described here are based on generic file locations. Your system may have the files in different directories. Adapt the commands accordingly.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening a case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using SAP for Me, Google or Bing:
- https://me.sap.com/servicessupport/search#?q=SAP%20Analytics%20Cloud%20OR%20SAC&tab=All
- https://www.google.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fuserapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
linux, ulimit, java, exception, files, limit, error, tomcat, agent, inaccessible, unreachable, url, C4A_AGENT, deploymentInfo, cloud, restart, boot. , KBA , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Known Error