SAP Knowledge Base Article - Public

3601089 - Runtime Error TIME_OUT occurring when changing Settlement Period and Billing Date rules in Service Contracts - SAP S/4HANA Cloud Public Edition

Symptom

When changing both the Billing Date rule and Settlement Period rule to "On Settlement Start Date (Billing Date)" in a service contract item billing plan, the system hangs and eventually results in a TIME_OUT error (500 Connection Timed Out).

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Open a service contract in the Manage Service Contracts app
  2. Click on the Edit button
  3. Navigate to item details and the Billing Plan section
  4. Change Billing Date rule to "On Settlement Start Date (Billing Date)"
  5. Change Settlement Period to "On Settlement Start Date (Billing Date)"

Cause

Not all the options listed in the "Settlement Period" dropdown list can be selected as a settlement period rule. The "Settlement Period" and "Billing Date" share the same source list, and the options specialized for the settlement period or billing date have the corresponding suffix in brackets.

Resolution

Select the options for "Settlement Period" without a (Billing Date) suffix and the options for "Billing Date" without a (Settlement Period) suffix.

See Also

Keywords

Service Contract, Billing Plan, Timeout Error, Settlement Period, Billing Date, ABAP Runtime Error, 500 Connection Timed Out, Application Server Error, TIME_OUT , KBA , CRM-S4-SRV-CTR-2CL , S4CRM: Service Contract (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions