Symptom
Picklist fields defined on the Application show with an incorrect order on the Latest Workbench. On the Legacy Workbench view, the order is correct.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Review an Application where there is a Picklist field that the User has write permissions to.
- View the Order of the fields in the Legacy Workbench.
- They appear in the correct order.
- Now switch to the Latest Workbench view & access the same Picklist on that Application.
- The order is different, with the options appearing incorrectly.
Note: The issue is happening in both the UXR and CX pages.
Cause
This is a known H1 2025 Release related issue.
Resolution
Engineering have confirmed that this issue with be Patched in the upcmong Patch release cycle. The dates are;
Preview: Tuesday May 13th
Production: Thursday May 15th
Keywords
Picklist Centre, Custom, Alphabetical, selection, Candidate Experience, reimagined, KI2505. , KBA , LOD-SF-RCM-APP , Applicants and Job Applications , Known Error