SAP Knowledge Base Article - Public

3601735 - Error while posting goods issue in app Manage Outbound Deliveries in SAP S/4HANA Cloud Public Edition

Symptom

  • An error occurs while trying to post goods issue in app Manage Outbound Deliveries.
  • The error message displayed is: “A critical error occurred. Contact your system administrator”.
  • The error occurs when outbound delivery contains ~10000 items.

Environment

SAP S/4HANA Cloud Public Edition

Reproducing the Issue

  1. Enter app Manage Outbound Deliveries.
  2. Select the delivery and click 'Post GI'.
  3. After waiting for around 10 minutes, the error pops up.

Cause

The 'Post Goods Issue' action aborts due to a DP_SOFTCANCEL_ICM_PROCESSING_TIMEOUT exception. This timeout is triggered by a statically configured threshold configured for the ICM layer after reaching the maximum HTTP Processing time, after which the processing is automatically aborted. The reason for the long runtime is that the large amount of items (~10.000) processed. Depending on the exact business process, the goods movement action triggers various follow-up actions in sales, finance, material management, etc. which can significantly prolong processing before a 'successful' goods movement can be confirmed.  

Resolution

Use app Schedule Goods Issue For Deliveries(F2259) to schedule a (recurring) background tasks for the GI posting of a delivery.

Keywords

Outbound delivery, Post Goods Issue, Large amount of items, A critical error occurred, DP_SOFTCANCEL_ICM_PROCESSING_TIMEOUT, Manage Outbound Deliveries, F2259 - Schedule Goods Issue For Deliveries. , KBA , LE-SHP-FIO-2CL , Fiori Apps - Delivery Documents (Public Cloud) , Problem

Product

SAP S/4HANA Cloud Public Edition all versions