Symptom
Error to create lead via mobile app: Failed to create lead: Account or Individual customer is required for leads. ValidateLeadRoot
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Login to the SAP Sales Cloud app
- At home page click on the + button
- Select Lead
- Uncheck the toggle button for 'Use Existing account'
- Fill the required fields
- Save and open
- Error: Failed to create lead: Account or Individual customer is required for leads. ValidateLeadRoot
Cause
Account or Individual customer are mandatory when creating lead. It's possible to select existing account or disable the 'Use Existing account' and then create a prospect account.
Resolution
In order to create a prospect account in mobile please follow below steps:
- Go to the User Menu
- Choose Settings
- Select All Settings
- Search and Open Mobile Administration --> Leads.
- Choose Create.
- Under Lead details click on add from list button.
- Under Account Details please add the Name field.
- Then it will be visible the 'account name' field in the lead create view for mobile app, which will allow to create prospect account.
Keywords
Account, Lead, Failed, Mobile, ValidateLeadRoot, Customer , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To
Product
SAP Sales Cloud and SAP Service Cloud Version 2 1.0