SAP Knowledge Base Article - Public

3602405 - Error 'Failed to create lead' in SAP Sales Cloud Mobile App

Symptom

Error to create lead via mobile app: Failed to create lead: Account or Individual customer is required for leads. ValidateLeadRoot

Environment

SAP Sales Cloud and SAP Service Cloud Version 2

Reproducing the Issue

  1. Login to the SAP Sales Cloud app
  2. At home page click on the + button
  3. Select Lead
  4. Uncheck the toggle button for 'Use Existing account'
  5. Fill the required fields
  6. Save and open
  7. Error: Failed to create lead: Account or Individual customer is required for leads. ValidateLeadRoot

Cause

Account or Individual customer are mandatory when creating lead. It's possible to select existing account or disable the 'Use Existing account' and then create a prospect account. 

Resolution

In order to create a prospect account in mobile please follow below steps: 

  1. Go to the User Menu
  2. Choose Settings
  3. Select All Settings
  4. Search and Open Mobile Administration  --> Leads.
  5. Choose Create.
  6. Under Lead details click on add from list button.
  7. Under Account Details please add the Name field.
  8. Then it will be visible the 'account name' field in the lead create view for mobile app, which will allow to create prospect account.

Keywords

Account, Lead, Failed, Mobile, ValidateLeadRoot, Customer , KBA , CEC-CRM-MOB-ADM , Mobile Administration for SAP Sales/Service Cloud , How To

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0