Symptom
You are not able to filter out the Outbound Message using the Entity Key fields, like Display ID or ID.
Environment
Sales Cloud Version 2
Service Cloud Version 2
Reproducing the Issue
- Go to Settings
- Go to Message Monitoring
- Switch to Outbound View
- Click on Filter by ID
- Enter the Entity or Display ID
No results.
Cause
Not all the Message Entity types are currently supported for Key filters. This is why some specific message entities work and others do not.
Technically reason, the Entity filter functionality is limited to messages processed by a mapper that extracts and provides the mandatory keys to the Data connector service.
Resolution
The filter's current application is limited to select message types; full functionality across all message types will be implemented in the future.
Keywords
entity ID;entityDisplayId;externalReferenceKey;externalId;filterby;message monitoring;entity key , KBA , CEC-CRM-DC , Data Connector for SAP Sales/Service Cloud , Product Enhancement