Symptom
While you can add individual products to favorites and also create folders, when you configure a product and click the "View Favorites" button, only the folders appear.
Environment
SAP SALES CLOUD CPQ
Reproducing the Issue
- Log in to CPQ.
- Create a quote.
- Navigate to the catalog.
- Select a product.
- Click on the "Add to Favorites" icon.
- Enter a description and click "Save."
- Access the Favorites section.
- The product will be visible in Favorites.
- Configure another product.
- Click on the "Add to Favorites" icon on the right side.
- Enter a description, enable the "Create new folder" option, provide a folder name, and click "Save."
- Click on the "View Favorites" icon located near the "Add to Favorites" icon.
- You will be redirected to the Favorites screen, where only folders will be displayed, not the newly added products plus folders.
Cause
This is an expected behavior.
Resolution
When accessing Favorites in CPQ, the system displays the contents of the most recently visited favorites folder rather than a list of recent folders. This display includes favorites and sub-folders relevant to the product you are currently configuring. If you're using the configurator and click "View Favorites," you'll be redirected to the last visited favorites folder, showing only those favorites relevant to the product in the configurator. If no relevant favorites exist, the section will be empty. Similarly, when "View Favorites" is accessed from a quote item, it displays favorites from the last accessed folder that are tied to the quote item's product. If there are no applicable favorites, none will be shown. It's important to note that "View Favorites" only filters and shows favorites pertinent to the selected product, not all favorites in the folder. Any sub-folders within the last visited favorites folder will also be displayed, providing easy navigation to related configurations and preferences.
Keywords
CPQ, favorites, folder, favorite, save, product, quote , KBA , CEC-SAL-CPQ , Sales Cloud CPQ , Bug Filed