Symptom
The External System field in the product header is still pointing to the previous ERP system and not to the new converted S/4HANA, even tough under web service message monitoring, the S/4HANA system ID appears and it is filled in the incoming payload.
Environment
- SAP Cloud for Customer
- SAP Cloud for Customer Integration with S/4HANA
- SAP Cloud for Customer Integration with ERP
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for Product ID 123456 (where 123456 represents the Material ID).
The party shows the S/HANA
- Go to the Products work center.
- Search for Product ID 123456
It is displayed as old ERP System ID.
Cause
External system is filled as old ERP system ID because the data was created by ERP Technical User.
Then, you replicate the data from S/4HANA to C4C and the Product was updated by S/4HANA Technical User. It created a new ID Mapping, however, the creation identify is still linked to the Active ERP system.
Resolution
Then, as you are converting your ERP to S/4HANA, please check the SAP Blog Post S/4HANA Conversion with Integration to SAP Cloud for Customer.
See Also
Keywords
C4C, Cloud for Customer, ERP, S/4HANA, Material, Products, External System, ID Mapping, System ID. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To