Symptom
The error message "Gender Gender not known does not match the title." occurs when replicating a Business Partner from S/4HANA to C4C. Even the customer in S/4HANA doesn't have a gender assigned.
Environment
- SAP Cloud for Customer
- Integration of C4C with S/4HANA
Reproducing the Issue
- Go to the Administrator work center.
- Go to the General Setting work center view.
- Open the Web Service Message Monitoring under System Administration.
- Select query All.
- Search for message ID with error: "Gender Gender not known does not match the title".
Cause
The error arises due to a mismatch in the gender code. In the incoming payload, the Title (field <FormOfAddressCode> ) corresponds to a gender which is not aligned with the Gender Code passed via field <GenderCode>. This mismatch between the Title and Gender Code is causing the error.
C4C Gender Codes:
0 Gender not known
1 Male
2 Female
3 Nonbinary
9 Gender not specified
Resolution
- Ensure that the Gender Code passed in the incoming payload matches the Title.
- Align the Gender Code and the Title in the incoming payload as per the definitions in the C4C Business Configuration for Titles.
Keywords
S4, C4C, Business Partner, Replication, Error, Gender Code, Gender not known, Title, Mismatch. , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , LOD-CRM-INT-S4H , Integration of C4C with S/4 HANA , How To
SAP Knowledge Base Article - Public