Symptom
In the service order or service confirmation, the error "The selected registered Product is not available for this account" occurs.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Service Orders work center.
- Go to the Service Order Processing view.
- Created a new service order and enter the account ABC. (ABC represents the ID of the account)
- Click View All and go to Accounts and Affected Product tab.
- In the Affected Products section, enter the Registered Product XYZ, which is not registered for the account ABC, press enter. (XYZ represents the registered product ID)
- System shows the error "The selected registered Product is not available for this account".
Cause
The error occurs because the registered product is not for the account ABC. So it is not possible to use it in the service order.
Resolution
Select a proper registered product from the value help, the error will be removed.
Keywords
The selected registered Product is not available for this account; service order; service confirmation. , KBA , SRD-CRM-SEO , Service Orders , Problem
Product
SAP Business ByDesign all versions