Symptom
External key column is not available in the export file from Data Import and Export view.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2
Reproducing the Issue
- Go to User Menu.
- Go to Settings.
- Open Data Import and Export view.
- Click on export button.
- Select the entity and file type.
- Export the data.
- Open the exported file.
- Notice the external key column is not available.
Cause
ID mapping was not enabled for the entity or the entity is not supported for ID mapping.
Resolution
Enable the ID mapping by following the below steps:
- Go to User Menu.
- Go to Settings.
- Open ID Mapping, under Data Import and Export section.
- Enable ID mapping for the entity.
Once you activate ID mapping for an entity, the external keys used in the Import Create mode file for that entity will be retained and can be reused instead of Technical IDs to make subsequent updates and to cross reference in other entities via Import Update mode.
Please check the 'See Also' section to review the supported entities for ID mapping.
See Also
Keywords
ID Mapping, External Key, Import, Export, Column , KBA , CEC-CRM-IMX , Data Import/Export for SAP Sales/Service Cloud , How To