Symptom
Error happens with MM posting:
Message ID fins_acdoc_post111
"OI managed account &1 / &2 is not allowed in the transaction MKPF."
Environment
SAP S/4HANA Cloud Public Edition
Cause
The error is related to the account being posted. As indicated in the error message, "OI (Open Item) managed G/L account not allowed," G/L account clearing cannot be performed on a ledger-specific basis.
This means that if the account is open-item managed (requiring clearing), and there are value discrepancies across different ledgers, the system will block the posting.
To investigate further, refer to the "Display Material" app under the "Account 1" tab. Here, you can check the pricing for both 0L and 2L (example) in company code currency and group currency. Even if the current prices appear identical, historical data might reveal discrepancies, which could have triggered this error.
Resolution
Using an open-item managed G/L account in MM does not appear to be the optimal approach. While it might work for certain materials, this is often coincidental, as it depends on ledger values being identical. If there are differences between ledgers, the error FINS_ACDOC_POST111 is likely to occur again, making this solution unreliable and unstable.
The recommended solution remains as follows:
- Deactivate Open Item Management for the relevant G/L account. See details in SAP Help Portal: Activate Open Item Management for G/L Accounts
Or - Use a different account without Open Item Management for the posting.
See Also
KBA 3380537 - Parameters Not Available in Job Activate Open Item Management for G/L Accounts in Production System - SAP S/4HANA Cloud Public Edition
Keywords
FINS_ACDOC_POST111, FINS_ACDOC_POST 111, OI, open item, not allowed. , KBA , FI-GL-GL-A-2CL , Posting/Clearing (Public Cloud) , CO-PC-ML-2CL , Material Subledger (Public Cloud) , Problem