SAP Knowledge Base Article - Public

3605594 - Error Code: SAE1 - Unable to Approve or Decline Leave Request in SAP SuccessFactors Time Off

Symptom

  • An error occurs when attempting to approve or decline a leave application in SAP SuccessFactors Time Off
    • The error message displayed is "An error occurred. Please contact your administrator. Code: SAE1". OR
    • When clicking on Approve or Decline the following error comes up:
      "Oops! We couldn’t process your response. Please approve or decline again."

      After clicking on Show Errors a warning appears on SF UI under "Approvals" > Time Off tile ("Error in processing. Please try again.")

Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental. 

Environment

  • SAP SuccessFactors Employee Central
    • Time Off
    • Time Sheet

Reproducing the Issue

  1. Proxy as the manager of the affected user.
  2. Navigate to "Administer Time for..".
  3. Enter the affected user's details.
  4. Attempt to approve or decline the pending leave request.

Cause

  • The issue arises due to the presence of two leave request records (cancelled and pending) for the same period.
  • Both records refer to the same attachment and attachment ID, causing a lock and preventing overwrite (decline/approve).

Resolution

  1. Download the attachment associated with the leave request.
  2. Re-upload the downloaded attachment. This generates a new attachment ID and updates the lock ID.

See Also

SAP Note 2919530 - Code: SAE1 error showing in Time Off or Time Sheet

Keywords

SAP SuccessFactors Employee Central, EC, Time Off, Time Sheet, Leave Application, Leave Request, Approve, Decline, Error Code: SAE1, Attachment, Lock , KBA , LOD-SF-EC-TIM , Time Off , LOD-SF-EC-TMS , Time Sheet , Problem

Product

SAP SuccessFactors Employee Central all versions