SAP Knowledge Base Article - Public

3605895 - External ID Mapping Is Missing In The Integration Settings

Symptom

"External ID Mapping" is suddenly missing on UI.

Environment

SAP Sales & Service Cloud Version 2

Reproducing the Issue

  1. Open the Sales & Service Cloud V2
  2. Navigate to Settings
  3. Navigate to Integration section
  4. You found "External ID Mapping" is suddenly missing

Cause

"External ID Mapping" was missing for few hours due to migration of the corresponding microservice to new repository. 

Resolution

The movement has been completed. You need to do below activity to fix the issue.

If you go to corresponding business role of the logged-in user, you can see the warning "Some of the business services assigned to the business role is no longer valid. Please delete all the services with a warning sign to proceed further."

The old service "sap.crm.service.externalIdAdminService" has to be deleted from the list and new service "sap.crm.service.externalIdMappingService" has to be added. Then the ID Mapping will be seen on UI.

Keywords

"External ID Mapping" ; "ID mapping missing" , KBA , CEC-CRM-INT , Integration for SAP Sales/Service Cloud , Problem

Product

SAP Sales Cloud and SAP Service Cloud Version 2 1.0