Symptom
You have restricted the customer role within code list restriction for the business user, but role is still visible in account owl but not within account's advance filter.
Environment
SAP Sales Cloud and SAP Service Cloud Version 2.
SAP Sales Cloud Version 2.
SAP Service Cloud Version 2.
Reproducing the Issue
- Login to the system with logon user PQR (where PQR represent the User name).
- Go to the User Menu and click on the Settings.
- Go to the All Settings and click on Code List Restriction.
- Go to the Business Entity as an Account.
- Search and open the code list restriction CLR (where CLR represent the code list restriction name).
- Here the Code to Restrict is Role and under Allowed Value, the Code Value LMN (where LMN represent one of the account's roles) is restricted to Business Role XYZ assigned to logon user PQR.
- Go to the Navigation Menu and search with entity Account.
- Here, you have standard search Role field, where you able to see the role as LMN which is restricted to the current logon user PQR.
- If you click on advance filter and search role LMN under field name Role, you cannot see the role LMN here.
Cause
We currently had a discrepancy where code list restriction is restricted in Account's advance filter but not within Account's OWL.
Resolution
We have provided fix, now code list restriction both in the advanced find form and owl will not be restricted.
Keywords
Code List Restriction, Account, Customer, OWL, Advance filter, Role Code , KBA , CEC-CRM-ACC , Account for SAP Sales/Service Cloud , Problem